вывести элементы массива значения которых меньше их индекса.
Помогите составить программу (Паскаль), оформить ответ!
Ответы на вопрос
Ответил Аноним
0
var a: array[1..10] of integer; i: integer;
begin
Writeln('Массив ');
for i := 1 to 10 do begin
a[i] := random(10);
write(a[i], ' ');
end;
Writeln;
writeln('Числа и их индекс (по условию)');
for i := 1 to 10 do
if i > a[i] then write('(', a[i], ' - ', i, ') ');
end.
begin
Writeln('Массив ');
for i := 1 to 10 do begin
a[i] := random(10);
write(a[i], ' ');
end;
Writeln;
writeln('Числа и их индекс (по условию)');
for i := 1 to 10 do
if i > a[i] then write('(', a[i], ' - ', i, ') ');
end.
Новые вопросы