Информатика, вопрос задал astaexe , 1 год назад

Выполните задания по теме «Программирование циклов на паскале»:
1.Определите, что будет напечатано в результате следующего алгоритма.
Var s,k:integer;
begin
s:=0;
For k:=1 to 12 do s:=s+5;
writeln(s);
end.
2.Написать программу для вывода на экран кубов чисел от A до B, которые вводит пользователь.
3.Написать программу:Найти сумму n элементов следующего ряда чисел:1, -0.5, 0.25, -0.125…… Количество элементов (n) вводится с клавиатуры
4.Дано вещественное число — цена 1 кг конфет. Вывести стоимость 0.1, 0.2, …, 1 кг конфет.
Написать программу для решения этой задачи
5. написать программу вывода на экран натуральных чисел от 1 до 9​

Ответы на вопрос

Ответил fovfabomi
1

1)60

2)var a,b: integer;

begin

 readln(a,b);

 while a<=b do begin writeln(a*a*a); a:=a+1; end;

end.

3) var a,s,n,d:real;

b:=-0.5;

begin readln(n);

a:=1;

s:=1;

d:=1;

while a<n do begin d:=b*d;s:=s+d; a:=a+1 end;

writeln(s)

end.

4) var a,s: real;

begin

 writeln('введите стоимость килограмма');

 readln(s);

 a := 0.1;

while a<=1 do

begin

writeln(a*s);

a:=a+0.1;end

end.

5)var a: integer;

begin

 a:=1;

 while a<=9 do begin writeln(a); a:=a+1; end;

end.

Новые вопросы