Выполнить задания на Pascal
1) Найти сумму максимальных элементов и количество четных чисел в двух массивах. Массивы хранят только целые значения. Заполнения массива случайными числами и вывода массива на экран, нахождение максимального элемента в массиве и нахождения количества четных элементов оформить в виде подпрограмм-процедур.
Организовать меню программы:
1. Ввод елементов
2. Вывод на экран
3. Нахождение мах
4. Нахождение кол-ва четных элементов
5 Выход
2) Одномерный массив из n элементов целых чисел в диапазоне от -30 до 30 заполняется случайными числами. Найти кол-во чисел, находящихся в диапазоне от -5 до 5. Подсчитать сколько чисел равных 0.
3) Розробити програму: ввести 10елементів масиву цілих чисел та обчислити суму елементів, у яких непарні (нечетные) індекси
4) 1. Найти произведение всех чисел от 1 до n.
2. Умножение числа а = 12345679
на числа 9, 18, 27, ... 81 дает интересные результаты. Напишите программу
получения этих произведений.
3. Дано натуральное число. Заменить все цифры 7 в
данном числе цифрами 8 и удалить из записи числа все единицы. Например, для
175718 новое число равно 8588.
Ответы на вопрос
Ответ:
1(точно не могу сказать работает или нет):
program Main;var
A, B: array[1..10] of integer;
max1, max2: integer;
sum: integer;
evenCount1, evenCount2: integer;
i: integer;procedure Input;
begin
for i := 1 to 10 do
begin
A[i] := random(100);
B[i] := random(100);
end;
end;procedure Output;
begin
for i := 1 to 10 do
begin
write(A[i], ' ');
end;
writeln;
for i := 1 to 10 do
begin
write(B[i], ' ');
end;
writeln;
end;function Max(arr: array of integer): integer;
var
max: integer;
i: integer;
begin
max := arr[1];
for i := 2 to 10 do
begin
if arr[i] > max then
begin
max := arr[i];
end;
end;
Max := max;
end;function EvenCount(arr: array of integer): integer;
var
evenCount: integer;
i: integer;
begin
evenCount := 0;
for i := 1 to 10 do
begin
if arr[i] mod 2 = 0 then
begin
evenCount := evenCount + 1;
end;
2:
program Main;var
a: array[1..10] of integer;
n, i, k, cnt1, cnt2: integer;begin
randomize;
n := 10;
cnt1 := 0;
cnt2 := 0;
for i := 1 to n do
begin
a[i] := random(61) - 30; // генерируем случайное число от -30 до 30
if (a[i] >= -5) and (a[i] <= 5) then
inc(cnt1); // увеличиваем счетчик чисел в диапазоне от -5 до 5
if a[i] = 0 then
inc(cnt2); // увеличиваем счетчик чисел, равных 0
end;
writeln('Количество чисел в диапазоне от -5 до 5: ', cnt1);
writeln('Количество чисел, равных 0: ', cnt2);
end.
3:
program Main;
var
a: array[1..10] of integer;
i, sum: integer;
begin
sum := 0;
for i := 1 to 10 do
begin
readln(a[i]);
if (i mod 2) <> 0 then // проверка нечетности индекса
sum := sum + a[i];
end;
writeln('Сумма елементів у яких непарні індекси: ', sum);
end.
4:
4.1:
program Main;
var
i, n, result: integer;
begin
result := 1;
write('Введите n: ');
readln(n);
for i := 1 to n do
result := result * i;
writeln('Произведение чисел от 1 до ', n, ': ', result);
end.
4.2:
program multiplication;
var
a, b, c: integer;
begin
a := 12345679;
for b := 9 to 81 do
begin
c := a * b;
writeln(a, ' * ', b, ' = ', c);
end;
end.
4.3:
program ReplaceAndDelete;
var n, res: longint;
begin
write('Введите число: ');
readln(n);
res := 0;
while n > 0 do begin
if n mod 10 = 7 then res := res * 10 + 8
else if n mod 10 <> 1 then res := res * 10 + n mod 10;
n := n div 10;
end;
writeln('Результат: ', res);
end.