Вводится массив, состоящий из целых чисел. Определите, сколько из них положительные.
ВХОДНЫЕ ДАННЫЕ
Сначала задано число N — количество элементов в массиве (1≤N≤35). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
ВЫХОДНЫЕ ДАННЫЕ
Необходимо вывести одно целое число — количество положительных элементов массива.
ПРИМЕРЫ
ВВОД ВЫВОД
3
1
-2
0
1
Ответы на вопрос
Ответил Прогер777
0
program n1;
var n, k, i, c : integer; a:array[0..35] of integer;
begin
read(N);
if (N>=1)and(N<=35) then c:=n
else
begin
writeln('error');
read(N);
end;
for i:=1 to c do
begin
read(a[i]);
if A[i]>0 then k:=k+1;
end;
writeln(k);
end.
Как то так
программа была скопирована из компилятора и там работала по условию
var n, k, i, c : integer; a:array[0..35] of integer;
begin
read(N);
if (N>=1)and(N<=35) then c:=n
else
begin
writeln('error');
read(N);
end;
for i:=1 to c do
begin
read(a[i]);
if A[i]>0 then k:=k+1;
end;
writeln(k);
end.
Как то так
программа была скопирована из компилятора и там работала по условию
Ответил Прогер777
0
program n1;
var n, k, i: integer;
a:array[1..35] of integer;
begin
repeat
begin
write('Введите (1<=N<=35) >>> ');
read(n);
end;
until (n>=1)and(n<=35);
for i:=1 to n do
begin
read(a[i]);
if A[i]>0 then k:=k+1;
end;
writeln('количество положительных элементов массива [',k,']');
end.
var n, k, i: integer;
a:array[1..35] of integer;
begin
repeat
begin
write('Введите (1<=N<=35) >>> ');
read(n);
end;
until (n>=1)and(n<=35);
for i:=1 to n do
begin
read(a[i]);
if A[i]>0 then k:=k+1;
end;
writeln('количество положительных элементов массива [',k,']');
end.
Новые вопросы