Информатика, вопрос задал zaharyantsruzanna , 6 лет назад

Ввод и вывод одномерного массива 1. Составить программу ввода и вывода массива: а) из 10-ти чётных чисел: 2, 4, 6...; b) из 15-ти первых чисел, кратных числу 19; с) из 20-ти чисел: 1, 2, 1, 2...; d) 10-ти чисел: 1, 33, -5, 16, 0, 8, -17, 25, 44, 9; e) X = {11, 22, 33, 44, 55, 66, 77, 88, 99}; f) размера N> 1, степеней числа 2. ​

Ответы на вопрос

Ответил p15
0

Ответ:

Начнем с простого

d)

from array import *

x = array('i', [1, 33, -5, 16, 0, 8, -17, 25, 44, 9])

for i in x:

   print(i)

e)

from array import *

x=array('i')

for i in range(1,10):

   x.insert(i,i*11)

for i in x:

   print(i)

f)

from array import *

n=int(input())

x=array('i')

for i in range(1,n+1):

   x.insert(i,2**i)

for i in x:

   print(i)

a)

from array import *

n=10

x=array('i')

for i in range(1,n+1):

   x.insert(i,2*i)

for i in x:

   print(i)

b)

from array import *

n=15

x=array('i')

for i in range(1,n+1):

   x.insert(i,19*i)

for i in x:

   print(i)

c)

from array import *

n=20

x=array('i')

for i in range(2,n+2):

   x.insert(i,i%2+1)

for i in x:

   print(i)

Новые вопросы