Информатика, вопрос задал natasha98123 , 10 лет назад

Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального элементов.
(Составить программу Pascal)

Ответы на вопрос

Ответил Yegor55
0
uses crt;

const
    N = 10;

var
    a : array [1..N] of Real;
    i : Integer;
    max, min : Real;
begin
    clrscr;

    for i := 1 to N do
    begin
        Write('a[', i,'] = ');
        Readln(a[i]);
    end;

    max := a[1];
    min := a[1];

    for i := 2 to N do
    begin
       if max < a[i] then max := a[i];
       if min > a[i] then min := a[i];
    end;

    Writeln(max - min:0:3);
    Readln;
end.
Новые вопросы