Информатика, вопрос задал SpyCandy , 9 лет назад

Введено число от 1 до 1000 включительно. Написать программу, с помощью которой можно найти сумму цифр числа, введенного пользователем. Писать на С++

Ответы на вопрос

Ответил nikolac
0
#include <iostream>
using namespace std;
int n;
int sum_digits(int n)
{
  int res = 0;
  while (n > 0)
  {
    res += n % 10;
    n /= 10;
  }
  return res;
}
int main()
{
  cin >> n;
  cout << sum_digits(n);
  return 0;
}
Новые вопросы