Информатика, вопрос задал ooppphhhddhbs , 2 года назад

всем привет, задание решить нужно на PYTHON(пайтон), не отправляйте ответы с интернета и тем более ответы на других языках программирования и пожалуйста, напишите глупые ответы что бы получить баллы. очень надеюсь на вашу помощь и понимание.

само задание вот:


Составить программу для вычисления суммы: 2! + 4! + 6! + + ... + n! (n< 16, n – парное).​

Ответы на вопрос

Ответил p15
1

Ответ:

def factorial(t):

   f=1

   for i in range (1,t+1):

       f*=i

   return f

n=int(input())

S=0

for i in range (2,n+1,2):

   S+=factorial(i)

print(S)

Объяснение:

В принципе можно вводить и нечетные. Посчитает до ближайшего четного (например если ввести 7, то посчитает до 6)

Проверил на 16 - считает быстро. Есть идея как еще ускорить, но не вижу смысла и так быстро считает.


ooppphhhddhbs: та я вижу, я опечатался , говорю ж
p15: я думал это про прогу
ooppphhhddhbs: такой вопрос
ooppphhhddhbs: можешь ли ты сделать этот код с рекурсией ?
ooppphhhddhbs: то препод отказался хавать код без рекурсии
p15: создавай новый вопрос. в задании напиши обязательно про рекурсию. если будет вечером время и желание, то сделаю. может кто-то другой сделает к тому времени.
p15: на самом. деле только переписать функцию.
ooppphhhddhbs: я создал
ooppphhhddhbs: и мой вопрос опять поставили в категорию 1-4 классы, хотя я брал 10-11 класс
p15: странно. мне кажется это зависит от настроек твоего профиля
Новые вопросы