Информатика, вопрос задал MisterHipster , 7 лет назад

Всем привет! Кому не трудно, нужно выполнить данные программы в Паскаль и показать результат. На компьютере. Пожалуйста, ерунду всякую не писать. Буду признателен) Желательно скриншот. Спасибо) Дам 40 баллов.


Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае:


Сумма цифр данного трехзначного числа N является четным числом.


Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.


Треугольник со сторонами a, b, c является равнобедренным.

Приложения:

Ответы на вопрос

Ответил ingr
0

подправил твою 1-ю программку. Тестил в ПаскальАБЦ но по идее работать должно в любом.

var

   num : integer;

   n1, n2, n3 : integer;

begin

   write('введите 3-значное число: ');

   readln(num);

   n1 := (num div 100);

   n2 := (num mod 100 div 10);

   n3 := (num mod 10);

   if (n1+n2+n3) mod 2 = 0

   then writeln('четное')

   else writeln('нечетное');

end.

хотя я эту программу сделал бы как нибудь так:

var

   num : integer;

begin

   write('введите 3-значное число: ');

   readln(num);

   if ((num div 100)+(num mod 100 div 10)+(num mod 10)) mod 2 = 0 then writeln('четное') else writeln('нечетное');

end.

на остальные программы сейчас времени нет... может если попозже...

Ответил ingr
0
для начала read лучше поменять на readln это не ошибка но так лучше
Ответил ingr
0
парсинг цифр лучше сделать как я переделал для первой программы
Ответил ingr
0
для нахождения квадрата числа есть отдельная фенкция sqr(), поэтому лучше будет написать sqr(num) вместо умножения, хотя на результат это не повлияет
Ответил ingr
0
и в конце тебе нужно найти куб суммы цифр, а ты находишь сумму кубов цифр. Правильно будет (n1+n2+n3)*(n1+n2+n3)*(n1+n2+n3) но если у тебя ПаскальАБЦ то для этого тоже можно использовать функцию возведения числа в произвольную степень power(n1+n2+n3, 3)
Ответил MisterHipster
0
Спасибо)
Новые вопросы