Информатика, вопрос задал kodert , 7 лет назад

Вариант 2.
нет
исел в
1. Напишите программу, которая в последовательности натуральных чисел определ
максимальное число, оканчивающееся на 7. Программа получает на вход количесі
последовательности, а затем сами числа. В последовательности всегда имеется число,
оканчивающееся на 7.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 50 ооо.
2. Напишите программу, которая в последовательности натуральных чисел определяет сумму
чисел, оканчивающихся на 3. Программа получает на вход количество чисел в
последовательности, а затем сами числа.
3. Напишите программу, которая в последовательности натуральных чисел определяет количест
чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход количество чисел в
последовательности, а затем сами числа.

Ответы на вопрос

Ответил csharp
0

Задание 1

  1. var
  2.    i, N, inputNumber, max: integer;
  3. begin
  4.    Write('Введите количество чисел: ');
  5.    Readln(N);
  6.    
  7.    for i := 1 to N do
  8.        begin
  9.            Write('Введите число: ');
  10.            Readln(inputNumber);
  11.            
  12.            if (inputNumber mod 10 = 7) then
  13.                if (inputNumber > max) then
  14.                    max := inputNumber;
  15.        end;
  16.    
  17.    if (max = 0) then
  18.        Write('В последовательности нет чисел, оканчивающихся на 7')
  19.    else Write('Максимальное число, оканчивающееся на 7: ', max);
  20. end.

Задание 2

  1. var
  2.    i, N, inputNumber, sum: integer;
  3. begin
  4.    Write('Введите количество чисел: ');
  5.    Readln(N);
  6.    
  7.    for i := 1 to N do
  8.        begin
  9.            Write('Введите число: ');
  10.            Readln(inputNumber);
  11.            
  12.            if (inputNumber mod 10 = 3) then
  13.                sum := sum + inputNumber;
  14.        end;
  15.    
  16.    if (sum = 0) then
  17.        Write('В последовательности нет чисел, оканчивающихся на 3')
  18.    else Write('Сумма чисел, оканчивающихся на 3: ', sum);
  19. end.

Задание 3

  1. var
  2.    i, N, inputNumber, valueOfNumbers: integer;
  3. begin
  4.    Write('Введите количество чисел: ');
  5.    Readln(N);
  6.    
  7.    for i := 1 to N do
  8.        begin
  9.            Write('Введите число: ');
  10.            Readln(inputNumber);
  11.            
  12.            if ((inputNumber mod 10 = 4) and (inputNumber mod 3 = 0)) then
  13.                valueOfNumbers := valueOfNumbers + 1;
  14.        end;
  15.    
  16.    if (valueOfNumbers = 0) then
  17.        Write('В последовательности нет чисел, оканчивающихся на 4 и кратных 3-м')
  18.    else Write('Сумма чисел, оканчивающихся на 4 и кратных 3-м: ', valueOfNumbers);
  19. end.
Новые вопросы