Информатика, вопрос задал amirnasledea9631 , 6 лет назад

Вариант 1 Необходимо написать программу, которая будет принимать на вход алгоритма различные слова, при вводе слова «Стоп» программа должна перестать принимать слова и должна выводить на экран количество слов, длина которых не превышает 7 букв, а также, если при вводе встречалось слово «Привет», то должна еще и выводить приветствие в ответ: «И Вам добрый день.



Необходимо написать программу, которая будет принимать на вход алгоритма отрицательные целые числа от -100000 до -1. При вводе 0 или положительного числа программа должна переставать принимать числа и должна выводить на экран количество чисел, которые при возведении в квадрат больше 100, а также сумму чисел, которые делятся на 4 и на 6, но при этом на эти цифры не оканчиваются.
СРОЧНО НАДО!!!!!!!!!!!!!!!!

Ответы на вопрос

Ответил badnsnus
1

Ответ:

1)

c = 0

flag = 0

while True:

   a = input()

   if a == 'Стоп':

       break

   if a == 'Привет':

       flag = 1

   if len(a) < 8:

       c += 1

if flag == 1:

   print('И Вам добрый день')

print(c)

2)

s = 0

c = 0

while True:

   a = int(input())

   if a >= 0:

       break

   if a**2 > 100:

       c += 1

   if a % 24 == 0 and (a % 10 != 6 or a % 10 != 4):

       s += a

print(c)

print(s)


amirnasledea9631: это точно будет похоже на решение 9 класса?
amirnasledea9631: нужно чтобы решение было как в 9 классе
amirnasledea9631: если что в питоне
Новые вопросы