Вам дан массив из n целых чисел. Вы должны найти в этом массиве минимум и максимум, после чего подсчитать их усреднённое значение.
Формат входных данных
В первой строке входных данных находится одно натуральное число n (n≤105) — количество элементов в массиве.
Во второй строке находятся n целых чисел, не превышающих по модулю 109 — элементы массива.
Формат выходных данных
Требуется вывести усредненное значение минимума и максимума.
Примеры
Входные данные
5
7 2 1 8 5
Выходные данные
4.5
Ответы на вопрос
Ответил novilyalit1533
0
И что тут сложного?
#include <iostream>
using namespace std;
int main()
{
int n;
cin >> n;
int32_t arr[n];
for (size_t i = 0; i < n; ++i)
{
cin >> arr[i];
}
int32_t max = arr[0], min = arr[0];
for (auto &i : arr)
{
if (i > max) max = i;
if (i < min) min = i;
}
cout << static_cast<float>(max + min) / 2 << "n";
return 0;
}
Ответил RolonDor
0
Не объявлять массив с переменной в int
Ответил RolonDor
0
С переменной в []
Ответил csharp
0
А как тогда, по-Вашему, объявить массив на N элементов?
Новые вопросы