В С++ написать программу на вывод чисел по убыванию пример в описании
Приложения:

Ответы на вопрос
Ответил danulpopov
0
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n;
cin >> n;//количество чисел
vector<int> a(n);
for (int i = 0; i < n; ++i)
cin >> a[i];//ввод чисел
sort(a.begin(),a.end(),greater<int>());
for (int i = 0; i < n; ++i)
cout << a[i] << ' ';
}
//P.S. если что то не устраивает, то в коде, написанном на картинке поменяй знак в "if (x[i] < x[j])" на "if (x[i] > x[j])"
using namespace std;
int main()
{
int n;
cin >> n;//количество чисел
vector<int> a(n);
for (int i = 0; i < n; ++i)
cin >> a[i];//ввод чисел
sort(a.begin(),a.end(),greater<int>());
for (int i = 0; i < n; ++i)
cout << a[i] << ' ';
}
//P.S. если что то не устраивает, то в коде, написанном на картинке поменяй знак в "if (x[i] < x[j])" на "if (x[i] > x[j])"
Новые вопросы