Информатика, вопрос задал lalalala2299 , 2 года назад

в результате выполнения программы записанной ниже на экран будет выведено два числа A и B Укажите такое наибольшее число X при вводе которого на экран будет выведено сначала 3 а потом 5.
С ОБЪЯВЛЕНИЯМ, ПОЖАЛУЙСТА ​

Приложения:

Ответы на вопрос

Ответил pinguinbird
2

def check(x):

 a=0

 b=0

 while x>0:

   a=a+1

   if b<x%10:

     b=x%10

   x=x//10

 return[a,b]

for i in range(1000000):

 a = check(i)

 if a[0] == 3 and a[1] == 5: print(i)

Ответ: 555


otch1m007: а какой в итоге ответ
pinguinbird: 555, там написано в ответе :-)
HappyUnicorn00: неверноҰ
Новые вопросы