Информатика, вопрос задал MathTiger , 7 лет назад

В Python! Даю 50 баллов! СРОЧНО
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 9. Программа получает на вход числа в последовательности, ввод чисел осуществляется до тех пор, пока не будет введён 0. В последовательности всегда имеется число, оканчивающееся на 9.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: количество чисел, оканчивающихся на 9.
Пример работы программы:
Входные данные
19
29
24
0
Выходные данные
2​

Ответы на вопрос

Ответил tastydoshirak
1

Ответ:

s = 0

for i in range(0, 1000):

    a = input()

    if int(a) != 0:

        if str(a[-1]) == '9':

            s += 1

        if int(a) >= 30000:

            print('Слишком большое число!')

    else:

        break

print(f'Всего чисел: {s}.')


MathTiger: Спасибо
Новые вопросы