В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи.
Фибоначчи числа, элементы числовой возвратной последовательности 1, 1, 2, 3, 5, 8,... (ряда Фибоначчи), в которых каждый последующий член равен сумме двух предыдущих.
Ответы на вопрос
Program Fibonacci;
Uses Crt;
var i,n:integer;
{Итерационный метод вычисления чисел Фибоначчи}
function fib_it(n:integer):integer;
var a,b,c,i:integer;
begin
a:=1;b:=1;
if (n=1) or (n=2) then fib_it:=1
else begin
for i:=3 to n do
begin
c:=a+b;
a:=b;
b:=c;
end;
fib_it:=c;
end;
end;
{main program}
begin
clrscr;
write('Введите n: ');
readln(n);
for i:=1 to n do write(fib_it(i),' ');
readkey;
end.