Информатика, вопрос задал xxxloop , 6 лет назад

В питоне ввести последовательность целых чисел определить количество положительных четных чисел не превосходящих 256. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Ответы на вопрос

Ответил reyzuu
0

Ответ:

a=1

k=0

while a!=0:

   a=int(input('Введите число: '))

   if a>0 and a<=256 and a%2==0:

       k+=1

print('Количество положительных четных чисел,не превышающих 256:',k)

Новые вопросы