Информатика, вопрос задал Zelebobka22 , 1 год назад

в Питоне Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4.

Ответы на вопрос

Ответил ulrazvodova
3

Ответ: Считываем первое число(n), чтобы определить, до какого момента должен продолжаться цикл. Создаем переменную sum, чтобы хранить найденное количество чисел, удовлетворяющих условию. Запускаем цикл, считываем число, если последняя цифра - 4 (проверяем при помощи получения остатка от деления на 10) и число делится на 6 (проверяем при помощи получения остатка от деления на 6), то добавляем к в переменную sum 1.

n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

Объяснение: n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

Ответил Аноним
5

k = 0

N = int(input('Введите количество чисел в последовательности: '))

for i in range(N):

   a = int(input())

   if a % 10 == 4 and a % 6 == 0:

       k+=1

print(k)

Новые вопросы