Информатика, вопрос задал zloichibak , 9 лет назад

В паскале
Составьте программу, которая для произвольного натурального четырехзначного числа определяет сумму и произведение его цифр.

Ответы на вопрос

Ответил Аноним
0
var
  n, a, b, c, d, s, p: integer;

begin
  Write('Введите натуральное четырехзначное число: ');
  Readln(n);
  if (n > 9999) or (n < 1000) then Writeln('Число должно быть четырехзначным')
  else begin
    a := n div 1000; d := n mod 10; n := (n div 10) mod 100;
    b := n div 10; c := n mod 10;
    s := a + b + c + d;
    p := a * b * c * d;
    Writeln('Сумма цифр равна ', s, ', а их произведение равно ', p)
  end
end.

Тестовое решение:
Введите натуральное четырехзначное число: 2345
Сумма цифр равна 14, а их произведение равно 120


Новые вопросы