В паскале сформирвать массив из десяти элементов, заполнить его с помощью генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. Нужно написать программу.
Ответы на вопрос
Ответил preceptor
0
Program Task;
Var a: Array [1..10] of Integer;
i, tmp: Integer;
Begin
Randomize;
WriteLn('Сформированный массив:');
For i := 1 To 10 Do
Begin
a[i] := Random(10);
Write(a[i], ' ');
End;
WriteLn;
For i := 1 To 5 Do
Begin
tmp := a[i * 2];
a[i * 2] := a[i * 2 - 1];
a[i * 2 - 1] := tmp;
End;
WriteLn('Измененный массив:');
For i := 1 To 10 Do
Write(a[i], ' ');
ReadLn;
End.
Var a: Array [1..10] of Integer;
i, tmp: Integer;
Begin
Randomize;
WriteLn('Сформированный массив:');
For i := 1 To 10 Do
Begin
a[i] := Random(10);
Write(a[i], ' ');
End;
WriteLn;
For i := 1 To 5 Do
Begin
tmp := a[i * 2];
a[i * 2] := a[i * 2 - 1];
a[i * 2 - 1] := tmp;
End;
WriteLn('Измененный массив:');
For i := 1 To 10 Do
Write(a[i], ' ');
ReadLn;
End.
Новые вопросы
Информатика,
2 года назад
Биология,
2 года назад
Обществознание,
10 лет назад
Биология,
10 лет назад
История,
10 лет назад