Информатика, вопрос задал Redsedd , 2 года назад

В паскале
Напишите программу, которая вводит с клавиатуры трёхзначное число и находит разность между трёхзначным числом и числом, составленных из тех же цифр, но взятых в обратном порядке. Вывести на экран обратное число и полученную разность. Например, из числа 123 должно получиться число 321 и -198. Строки не использовать


gfhjkmgfhjkm20: Циклы проходили?
Redsedd: Не проходили, захотелось порешать для себя сложны задачи, проблемы с этой возникли

Ответы на вопрос

Ответил gfhjkmgfhjkm20
1

Ответ:

var a,b:integer;

begin

write('Введите трёхзначное число ');

readln(a);

b:=(a mod 10)*100+(a mod 100 div 10)*10+a div 100;

writeln('Обратное число ',b);

writeln('Разность ',a-b)

end.

Объяснение:

Для положительного трёхзначного числа.

Разбиваем на отдельные цифры используя операции целочисленного деления и остатка, умножаем полученные цифры на разряд.

Новые вопросы