Информатика, вопрос задал Aleksandra2185t , 7 лет назад

В паскале написать программу.Если первая (слева) цифра нечетная то вывести 1 ,если четная то вывести 2.Помогите пожалуйста.Даю 10б


restIess: первая слева?

Ответы на вопрос

Ответил restIess
1

uses math;

var  

   a: integer;

begin

   readln(a);

   a := abs(a);

   while a >= 10 do  

       a := a div 10;

   if (a mod 2 = 0) then

       writeln(2)

   else

       writeln(1);

end.

Новые вопросы