В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)
Ответы на вопрос
Ответил DarKsandr
0
var a, b, c, x1, x2, D:real;
begin
writeln ('Введите значение a, b и c');
readln (a, b, c);
D:=sqr(b)-4*a*c;
if D>0 then
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
writeln ('x1 = ', x1, ' x2 = ', x2)end
else
writeln ('Корней нет');
end.
begin
writeln ('Введите значение a, b и c');
readln (a, b, c);
D:=sqr(b)-4*a*c;
if D>0 then
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
writeln ('x1 = ', x1, ' x2 = ', x2)end
else
writeln ('Корней нет');
end.
Новые вопросы
Биология,
2 года назад
Физика,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад