Информатика, вопрос задал adsasdasdsdasd , 1 год назад

В ПАСКАЛЕ
1. Тор и Локи

Ограничение времени 1 секунда

Ограничение памяти 64Mb

Ввод стандартный ввод или input.txt

Вывод стандартный вывод или output.txt

Жители Асгарда, прежде всего, ценили физическую силу, упорство и храбрость в сражениях. Поэтому даже в школе математику они изучали на примере своих любимых (и не очень) героев. Однажды учитель задал им следующую задачу: «Сила Тора больше на N силы Локи, а сила Локи меньше силы Тора в M раз.


Определите, какая сила у Тора и Локи». Самому талантливому ученику предложили решить эту задачу с помощью программного кода.


Формат ввода

На вход подаются два натуральных числа N и M, разделенных пробелом (1 ≤ N, M ≤ 10в4степени). Входные данные таковы, что силы являются целыми числами.


Формат вывода

На выходе требуется вывести два числа, разделенные пробелом: сила Тора и сила Локи. Результат будет сравниваться с правильным ответом с точностью 10в -6 степени.


Пример 1

Ввод Вывод

1 2

2 1

Пример 2

Ввод Вывод

20 5

25 5

Ответы на вопрос

Ответил fedrfedr
0

Ответ: такая же задача уже была сегодня, поэтому дублирую свой ответ еще раз:

program TorLoki;

var

 n, m: Integer;

 T, L: Double;

begin

 Write ('Введите N и M: ');

 ReadLn (n, m);

 L := n / (m - 1);

 T := L + n;

 WriteLn ('Сила Тора = ', T :10 :6);

 WriteLn ('Сила Локи = ', L :10 :6);

 ReadLn;

end.

Объяснение:

нужно решить систему уравнений:

T = L + N

T = L * M

получается

L * M - L = N

L (M - 1) = N

L = N / (M - 1)

это сила Локи, а для Тора:

Т = L + N или T = L * M можно и так и так

Новые вопросы