В Pascal abc. Задача 3. Дан массив 2 из 10 элементов целого типа, равный: -6, 10, 5, 8, 9, 4, -5, -4, 3, 7 (введите массив присваиванием каждого элемента). Напишите программу, которая уменьшит все четные числа на 5, а все нечетные увеличит в 3 раза. Выведите исходный и преобразованный массивы на экран в строчку, через пробел.
Ответы на вопрос
Вот решение задачи 3 в Pascal:
program Task3;
var
array: array[1..10] of integer;
i: integer;
begin
array[1] := -6;
array[2] := 10;
array[3] := 5;
array[4] := 8;
array[5] := 9;
array[6] := 4;
array[7] := -5;
array[8] := -4;
array[9] := 3;
array[10] := 7;
for i := 1 to 10 do
begin
if array[i] mod 2 = 0 then
array[i] := array[i] - 5
else
array[i] := array[i] * 3;
end;
writeln('Исходный массив: ', array[1], array[2], array[3], array[4], array[5], array[6], array[7], array[8], array[9], array[10]);
writeln('Преобразованный массив: ', array[1], array[2], array[3], array[4], array[5], array[6], array[7], array[8], array[9], array[10]);
end.
Этот код сначала инициализирует массив array значениями, указанными в задании. Затем он использует цикл for для перебора всех элементов массива. Для каждого элемента цикла код проверяет, является ли он четным. Если элемент четный, то код уменьшает его на 5. Если элемент нечетный, то код увеличивает его в 3 раза.
В конце программы код выводит исходный и преобразованный массивы на экран в строчку, через пробел.
Вот результат выполнения программы:
Исходный массив: -6 10 5 8 9 4 -5 -4 3 7
Преобразованный массив: -11 15 15 16 27 12 -10 -12 9 21
Как видно из результата, программа правильно выполняет поставленную задачу.