Информатика, вопрос задал aryaoswald , 9 лет назад

В Pascal ABC составить программу для подсчета четных цифр, используемых для записи произвольного числа X.
использовать цикл с предусловием, другого не проходили
ОЧЕНЬ СРОЧНО ПОЖАЛУЙСТА!!!!!

Ответы на вопрос

Ответил redra1n
0
program red;
var a,b:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a mod 2=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10) mod 2=0) and (a div 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10 <>0) then b:=b+1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100) mod 2=0) and (a div 100 <>0) then b:=b+1;
if (((a div 10) mod 10) mod 2=0) and ((a div 10) mod 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10<>0) then b:=b+1;
end;
writeln(b);
end.
Новые вопросы