В массиве,состоящем из 10 случайных чисел в интервале[-20;10],определите количество и сумму элементов кратных 3.Pascal ABC.9класс
Ответы на вопрос
Ответил estengseant
0
var a: array[0..10] of Integer;
i,sum,count: Integer;
begin
sum:=0;
count:=0;
for i:=0 to 9 do
begin
a[i]:=random(31)-10;
writeln('Число ',i+1,': ',a[i]);
end;
for i:=0 to 9 do
begin
if a[i] mod 3=0 then
begin
count:=count+1;
sum:=sum+a[i];
end;
end;
writeln('Сумма чисел: ',sum);
writeln('Кол-во: ',count);
end.
i,sum,count: Integer;
begin
sum:=0;
count:=0;
for i:=0 to 9 do
begin
a[i]:=random(31)-10;
writeln('Число ',i+1,': ',a[i]);
end;
for i:=0 to 9 do
begin
if a[i] mod 3=0 then
begin
count:=count+1;
sum:=sum+a[i];
end;
end;
writeln('Сумма чисел: ',sum);
writeln('Кол-во: ',count);
end.
Новые вопросы
Українська мова,
2 года назад
Русский язык,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад
Литература,
9 лет назад