В массиве R из 11 элементов хранится рост всех девочек класса, который равен соответственно 150, 156, 176, 164, 158, 170, 168, 163, 166, 175, 172. Напишите программу, подсчитывающую средний рост девочек класса.
Ответы на вопрос
Ответил jerrystreet
0
program n_1;
var r:array[1..11] of integer;
i:integer;
s, sred:real;
begin
writeln('Введите рост девочки');
for i:=1 to 11 do
readln(r[i]);
s:=s+r[i];
sred:=s/11;
writeln('sred=',sred);
end.
var r:array[1..11] of integer;
i:integer;
s, sred:real;
begin
writeln('Введите рост девочки');
for i:=1 to 11 do
readln(r[i]);
s:=s+r[i];
sred:=s/11;
writeln('sred=',sred);
end.
Ответил ПолинаХудова
0
А почему ни один из роста девочек никак не задействован?
Ответил jerrystreet
0
Разве пользователь не должен сам вводить росты девочек?
Ответил ПолинаХудова
0
Так куда их водить? Я же чайник
Ответил jerrystreet
0
Эта программа запросит у вас ровно 11 раз данные о росте девочек. Сначала ввели одно данное, нажали enter, затем другое данное.... И так 11 раз
Ответил ПолинаХудова
0
хорошо, спасибо большое
Новые вопросы