В массиве из 10 чисел есть положительные и отрицательные элементы.Вычислить сумму отрицательных элементов масива.
Составить программу на языке паскаль и блок-схему.заранее спасибо)
Ответы на вопрос
Ответил Alphaeus
0
Program Seleone;
const n=10;
var a:array[1..n] of integer;
sum, i: integer;
begin
writeln('*** alphaues is thinking... ***');
sum:=0;
for i:=1 to n do
begin
write('Введите ',i,'-e число ');
readln(a[i]);
if a[i] < 0 then sum := sum + a[i];
end;
writeln('Сумма отрицательных элементов равна ',sum);
end.
Приложения:

Новые вопросы