В массив сохранены результаты выполнения контрольной работы:
1)Подсчитать количество пятёрок
2)Определить средней балл за к/р
3)Определите количество учеников,подучивших за к/р выше среднего
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
const n=15;
var a: array[1..n] of integer;
i,k5,kns,sum: integer;
sb: real;
begin
randomize;
k5:=0;
kns:=0;
sum:=0;
write('оценки: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
if a[i]=5 then k5:=k5+1;
sum:=sum+a[i];
end;
writeln;
sb:=sum/n;
writeln('кол-во 5: ',k5);
writeln('ср арифм: ',sb);
for i:=1 to n do if a[i]>sb then kns:=kns+1;
writeln('кол-во уч >ср арифм: ',kns);
end.
const n=15;
var a: array[1..n] of integer;
i,k5,kns,sum: integer;
sb: real;
begin
randomize;
k5:=0;
kns:=0;
sum:=0;
write('оценки: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
if a[i]=5 then k5:=k5+1;
sum:=sum+a[i];
end;
writeln;
sb:=sum/n;
writeln('кол-во 5: ',k5);
writeln('ср арифм: ',sb);
for i:=1 to n do if a[i]>sb then kns:=kns+1;
writeln('кол-во уч >ср арифм: ',kns);
end.
Новые вопросы