В массив из 10 элементов записаны оценки группы учащихся. Составить программу, выводящую на экран количество оценок 2,3,4 и 5.(Паскаль абс) Информатика 10 класс
Ответы на вопрос
Ответил ArtemTitov
0
var q2,q3,q4,q5,i:integer;
x:array[1..10]of integer;
begin
for i:=1 to 10 do
begin
read(x[i]);
case x[i] of
2:int(q2);
3:int(q3);
4:int(q4);
5:int(q5);
end;
end;
writeln('2: ',q2);
writeln('3: ',q3);
writeln('4: ',q4);
writeln('5: ',q5);
end.
x:array[1..10]of integer;
begin
for i:=1 to 10 do
begin
read(x[i]);
case x[i] of
2:int(q2);
3:int(q3);
4:int(q4);
5:int(q5);
end;
end;
writeln('2: ',q2);
writeln('3: ',q3);
writeln('4: ',q4);
writeln('5: ',q5);
end.
Ответил ArtemTitov
0
var q2,q3,q4,q5,i:integer;
x:array[1..10]of integer;
begin
for i:=1 to 10 do
begin
read(x[i]);
if x[i]=2 then q2:=q2+1;
if x[i]=3 then q3:=q3+1;
if x[i]=4 then q4:=q4+1;
if x[i]=5 then q5:=q5+1;
end;
writeln('2: ',q2);
writeln('3: ',q3);
writeln('4: ',q4);
writeln('5: ',q5);
end.
x:array[1..10]of integer;
begin
for i:=1 to 10 do
begin
read(x[i]);
if x[i]=2 then q2:=q2+1;
if x[i]=3 then q3:=q3+1;
if x[i]=4 then q4:=q4+1;
if x[i]=5 then q5:=q5+1;
end;
writeln('2: ',q2);
writeln('3: ',q3);
writeln('4: ',q4);
writeln('5: ',q5);
end.
Ответил нэнэ
0
Спасибо
Ответил нэнэ
0
Проверила в паскале, но он почему-то не выводит кол-во оценок
Ответил нэнэ
0
Вывел,это у меня паскаль глюканул
Новые вопросы