В классе 20 учеников. Составьте программу, которая определяет количество учеников, чей рост превышает средний. Рост должен задаваться случайными числами в диапазоне от 150 до 190.
Напишите программу в текстовом документе, либо в программе Pascal ABC
Ответы на вопрос
Ответил lbvf23
0
Const n=20;
Var i, k:integer ;s:real ;
A:array [1..200]of Integer ;
Begin
S:=0;
For i:=1 to N do begin
Write(' ') ;
a[i]:=random(41)+150;
S:=s+a[i];
Writeln(' ', a[i]) ;
End;
S:=s/n;
For i:=1 to N do begin
If(a[i] >s) then k:=k+1;
End;
Writeln ( ' ', k) ;
End.
Новые вопросы