Информатика, вопрос задал sqas , 2 года назад

В данном массиве чисел найдите среднее арифметическое положительных элементов массива.
Составить программу для Pascal ABC

Ответы на вопрос

Ответил rustam1509
0
var    
     arr : array[1..99] of integer;
     N, s, k : integer;
begin
    read(N);
    for var i := 1 to N do begin
        arr[i] := random(-10, 10);
        writeln(arr[i]);
        if arr[i] > 0 then begin
            s += arr[i];
            k += 1;
        end
    end;
    writeln(s/k);
end.
Новые вопросы