Информатика, вопрос задал vika200372 , 10 лет назад

Умоляю,помогите составить программу... С клавиатуры одной строкой вводят имя и фамилию через пробел.Составьте программу,которая проверяет,совпадает ли последний символ имени и предпоследний символ фамилии...

Ответы на вопрос

Ответил varscat
0

Использовать латиницу

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
using std::strtok;

int main()
{
    char s[100];
    char *temp1;
    char *temp2;

    cout << "Enter the name and surname: ";
    cin.getline(s, 100);

    temp1 = strtok(s, " ");
    temp2 = strtok(NULL, " ");

    if(*(temp1 + strlen(temp1) - 1) == *(temp2 + strlen(temp2) - 2))
    {
        cout << "true" << endl;
    }
    else
        cout << "false" << endl;

   return 0;
}

Приложения:
Ответил denisov7
0

Var
s,fam,nam:string;
begin
writeln('Vvedite imy i familiy:');
readln(s);
nam:=copy(s,1,pos(' ',s)-1);
fam:=copy(s,pos(' ',s)+1,length(s));
if nam[length(nam)]=fam[length(fam)-1] then writeln('Sovpadayut') else writeln('Ne sovpadayut');

write('Dly vyhoda nagmite Enter');
readln;
end.

Приложения:
Новые вопросы