Информатика, вопрос задал someoneeeee111 , 2 года назад

УМОЛЯЮ,ПОМОГИТЕ С ПАСКАЛЕМ
1)
Вычислить оптимальный вес по формуле рост-100 (фактический вес V и рост H вводятся пользователем) и выдать одно из сообщений:
- у вас идеальный вес;
- вам нужно похудеть на n кг (n вывести);
- вам нужно поправиться на n кг (n вывести).
2)Составить программу, которая бы по последней цифре многозначного числа выдавала бы одно из сообщений:
число не делится ни на 2, ни на 5
число делится только на 2
число делится только на 5
число делится и на 2, и на 5.



someoneeeee111: лучше в free

Ответы на вопрос

Ответил PopCop312
2
1)
var v,h,i:real;
begin
readln(v);
readln(h);
i:=h-100;
if v=i then writeln('у вас идеальный вес') else 
if v>i then writeln('вам нужно похудеть на ', v-i,' кг ') else
writeln('вам нужно поправиться на ', i-v,' кг ');
end.

2)
var a:string;
b:integer;
begin
readln(a);
b:=strtoint(a[length(a)]);
if (b mod 2 <> 0) and (b mod 5 <> 0) then writeln('число не делится ни на 2, ни на 5');
if (b mod 2 = 0) and (b mod 5 <> 0) then writeln('число делится только на 2');
if (b mod 2 <> 0) and (b mod 5 = 0) then writeln('число делится только на 5');
if (b mod 2 = 0) and (b mod 5 = 0) then writeln('число делится и на 2, и на 52');
end.

someoneeeee111: а можешь еще 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,
PopCop312: var a: integer;
begin
readln(a);
if a=1 then writeln('S круга = ', pi*a*a);
if a=2 then writeln('S квадрата = ', a*a);
if a=3 then writeln('S треугольника = ',a*a*sqrt(3)/4);
end.
someoneeeee111: спасибо огромное!! это просто надо в паскаль вписать и все?
Новые вопросы