Умоляю, помогите с Паскалем
1. Пользователь вводит неотрицательное однозначное число A. Написать программу:
вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,
выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.
Ответы на вопрос
Ответил volova6472
1
1) по заданному радиусу: Program n1;
Uses CRT;
Var r,s: real;
begin
ClrScr;
writeln('Vvedite radius');
readln(r);
s:=r*r*pi;
Writeln('ploshad =',s:4:4);
readln
end. 2) по заданным сторонам:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storoni');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end. 3) по заданной сторонеProgram n1;
Uses CRT;
Var a,s: real;
begin
ClrScr;
writeln('Vvedite storony');
readln(a);
s:=a*a;
Writeln('ploshad =',s:4:4);
readln
end. 3) по одной стороне и высоте к ней:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storony i vysoty k nei');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end.
Uses CRT;
Var r,s: real;
begin
ClrScr;
writeln('Vvedite radius');
readln(r);
s:=r*r*pi;
Writeln('ploshad =',s:4:4);
readln
end. 2) по заданным сторонам:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storoni');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end. 3) по заданной сторонеProgram n1;
Uses CRT;
Var a,s: real;
begin
ClrScr;
writeln('Vvedite storony');
readln(a);
s:=a*a;
Writeln('ploshad =',s:4:4);
readln
end. 3) по одной стороне и высоте к ней:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storony i vysoty k nei');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end.
volova6472:
прости я не то написала!!!
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Алгебра,
7 лет назад