Turbo pascal
1. Напишите программу вычисления длин сторон треугольника a,b и c по указанным формулам.
Величины углов треугольника d ,e , f заданные в градусах, радиус описанной окружности R вводятся с клавиатуры. Градусы описанной окружности R вводятся с клавиатуры. Градусы d,e,f предварительно переведите в радианы x y z по формуле
a=2R sin x , b=2R sin y, c= 2Rsin z.
2.Для четырех произвольных чисел введенных с клавиатуры, выведите на экран соответствующие результаты. Если сумма первого И третьего чисел больше 150, то выведите эту сумму И все четыре числа.
Пожалуйста, помогите хотя бы с одним заданием, очень нужно, буду благодарна
Ответы на вопрос
Ответил petyaGavrikov
0
1)
var a,b,c,d,e,f,r,x,y,z:real;
begin
writeln('d, e, f:');
readln(d,e,f);
write('r = ');
readln(r);
x:=d*pi/180;
y:=e*pi/180;
z:=f*pi/180;
a:=2*r*sin(x);
b:=2*r*sin(y);
c:=2*r*sin(z);
writeln('a = ',a:5:2,' b = ',b:5:2,' c = ',c:5:2);
end.
Пример:
d, e, f:
90 60 30
r = 2.5
a = 5.00 b = 4.33 c = 2.50
2)
var a,b,c,d:integer;
begin
writeln('a, b, c, d:');
readln(a,b,c,d);
if a+c>150
then writeln('a+c = ',a+c,' a = ',a,' b = ',b,' c = ',c,' d = ',d);
end.
Пример:
a, b, c, d:
72 18 94 25
a+c = 166 a = 72 b = 18 c = 94 d = 25
var a,b,c,d,e,f,r,x,y,z:real;
begin
writeln('d, e, f:');
readln(d,e,f);
write('r = ');
readln(r);
x:=d*pi/180;
y:=e*pi/180;
z:=f*pi/180;
a:=2*r*sin(x);
b:=2*r*sin(y);
c:=2*r*sin(z);
writeln('a = ',a:5:2,' b = ',b:5:2,' c = ',c:5:2);
end.
Пример:
d, e, f:
90 60 30
r = 2.5
a = 5.00 b = 4.33 c = 2.50
2)
var a,b,c,d:integer;
begin
writeln('a, b, c, d:');
readln(a,b,c,d);
if a+c>150
then writeln('a+c = ',a+c,' a = ',a,' b = ',b,' c = ',c,' d = ',d);
end.
Пример:
a, b, c, d:
72 18 94 25
a+c = 166 a = 72 b = 18 c = 94 d = 25
Новые вопросы
Математика,
2 года назад
Литература,
2 года назад
Биология,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад