Требуется написать программу (на языке Паскаль) которая вводит с клавиатуры два числа, x и y-координаты точки на плоскость, а затем проверяет. Принадлежит
ли точка заштрихованной области
Приложения:

Ответы на вопрос
Ответил Gleb1Kosyrev
0
//PascalABC.NET 3.2 сборка 1318
Var
x,y:real;
begin
read(x,y);
if (x<=0) and (y<=0) and (y>=-x-2) and (y>=-1*sqr(x)) then
writeln('Принадлежит')
else
writeln('Не принадлежит');
end.
Пример ввода:
-1
-0.2
Пример вывода:
Принадлежит
Var
x,y:real;
begin
read(x,y);
if (x<=0) and (y<=0) and (y>=-x-2) and (y>=-1*sqr(x)) then
writeln('Принадлежит')
else
writeln('Не принадлежит');
end.
Пример ввода:
-1
-0.2
Пример вывода:
Принадлежит
Новые вопросы