Информатика, вопрос задал KollProfil , 7 лет назад

Требуется написать программу, которая будет выполнять действия описанные ниже. Желательно с комментированием. (Visual Studio, на c#)
Символы и их коды. Формирование строк
1.1. Дан символ C. Вывести его код (то есть номер в кодовой таблице).
1.2. Дано целое число N (32 ≤ N ≤ 126). Вывести символ с кодом, равным N.
1.3. Дан символ C. Вывести два символа, первый из которых предшествует символу C в кодовой таблице, а второй следует за символом C.

Ответы на вопрос

Ответил tarsep
0

1.1.

texttt{Console.WriteLine((int)C);}

1.2.

texttt{Console.WriteLine((char)N);}

1.3.

texttt{Console.WriteLine((char)(C - 1));}\texttt{Console.WriteLine((char)(C + 1));}

Новые вопросы