Информатика, вопрос задал shirby , 9 лет назад

!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!!
Составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. На экран должен быть выведен результат выполнения соответствующего арифметического действия. Для ввода знака использовать вспомогательную переменную типа char.

Ответы на вопрос

Ответил Аноним
0
var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
Ответил shirby
0
Спасибо огромное!! <3
Ответил Аноним
0
Немножко улучшил программу
Ответил APALoff
0
Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.






Ответил APALoff
0
По хорошему еще бы прикрутить проверку на деление на ноль, а то ведь без "защиты от дурака" код не слишком стабилен.
Новые вопросы