Тема: вложенные циклы
Составить программу
1. Вывести надпись будет ли билет счастливым (в нём 6 цифр).
p15:
условие счастья?
Ответы на вопрос
Ответил neironogamiiko
0
Брут-форс на C++:
#include <iostream>
using namespace std;
int main()
{
int numbers[6];
for(int i = 0; i < 6; i++) cin >> numbers[i];
int firstPart, secondPart;
for(int i = 0; i < 3; i++) firstPart += numbers[i];
for(int i = 3; i < 6; i++) secondPart += numbers[i];
if(firstPart != secondPart){
cout << "No" << endl;
return 0;
}
cout << "Yes" << endl;
return 0;
}
Input:
1 2 3 4 5 6
Output:
No
Input:
1 2 3 3 2 1
Output:
Yes
Input:
4 5 1 0 6 4
Output:
Yes
Ответил p15
0
Ответ:
ticket=input()
print('Yes' if sum(map(int,ticket[:3]))==sum(map(int,ticket[3:])) else 'No')
Объяснение:
А на С++ удав гораздо длиннее. (с)
Условие - сумма первых трех цифр и последних трех
Приложения:

Новые вопросы