Информатика, вопрос задал бобо , 10 лет назад

ТЕМА: МАССИВЫ
помогите плиз!

Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

Ответы на вопрос

Ответил Аноним
0
var
  i,n:integer;
  s,min:real;a:array[1..10]of real;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  if a[i]<0 then
     begin
     s:=s+a[i];
     n:=n+1;
     end;
  if a[i]<min then min:=a[i];
  end;
writeln;
s:=s/n;
for i:=1 to 10 do  if a[i]=min then a[i]:=s;
writeln('Среднее отрицательных:',s);
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');
end.
Новые вопросы