Информатика, вопрос задал abdusamisultan , 1 год назад

Task 1
Написать программу, которая проверяет: четное ли число, введенное пользователем.
Task 2
Пользователь вводит число, программа увеличивает его на 2, пока оно не станет равно 40.
Task 3
Напишите программу, которая определяет время суток. (Утро от 4 до 11, день от 12 до 16, вечер от 17 до 22)

JAVA
JAVA в скрипте JAVA

Ответы на вопрос

Ответил 4asnykgamer
1

Ответ: Не совсем в джаве разбираюсь но вроде правильно

Task 1

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner scanner = new Scanner(System.in);

       System.out.println("Введите число: ");

       int number = scanner.nextInt();

       if (number % 2 == 0) {

           System.out.println("Число четное");

       } else {

           System.out.println("Число нечетное");

       }

   }

}

Task2

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner scanner = new Scanner(System.in);

       int number = scanner.nextInt();

       while (number != 40) {

           number += 2;

           System.out.println(number);

       }

   }

}

Task3

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner scanner = new Scanner(System.in);

       int time = scanner.nextInt();

       if (time >= 4 && time <= 11) {

           System.out.println("Утро");

       } else if (time >= 12 && time <= 16) {

           System.out.println("День");

       } else if (time >= 17 && time <= 22) {

           System.out.println("Вечер");

       } else {

           System.out.println("Ночь");

       }

   }

}

Новые вопросы