Информатика, вопрос задал shurenovk , 2 года назад

СУПЕР ПУПЕР СРОЧНО ДАЮ 100 балловНапишите программу, которая из введенных N чисел ведет счет положительных чисел, отрицательных чисел и чисел равных нулю.



Вводные данные: в первой строке число N, затем на следующих N строках числа (-10000 <= ni <= 10000).

Исходные данные: на одной строке три числа, первое - количество положительных чисел, второе - количество отрицательных чисел и третье - количество нулей.

Ответы на вопрос

Ответил maxum000
3

Python

n = int(input())

s = []

result = [0,0,0]

for i in range(n):

   k = int(input())

   while not (-10000 < k < 10000):

       k = int(input("Out of range. Repeat: "))

   s.append(k)

for i in s:

   if i > 0:

       result[0] += 1

   elif i < 0:

       result[1] += 1

   elif i == 0:

       result[2] += 1

for i in result:

   print(i, end=" ")

Ввод/Вывод:

5                                                                                                                                

3                                                                                                                                

4                                                                                                                                

-4                                                                                                                              

-2                                                                                                                              

0                                                                                                                                

2 2 1


maxum000: Если вводимое число больше 10000 или меньше -10000, то программа будет запрашивать ввод до тех пор, пока число будем входить в этот диапазон
Новые вопросы