Информатика, вопрос задал zkirienko , 7 лет назад

Сумма двух списков На вход программе подаются две строки текста, содержащие целые числа. Из данных строк формируются списки чисел L и M. Напишите программу, которая создает третий список, элементами которого являются суммы соответствующих элементов списков L и M. Далее программа должна вывести каждый элемент полученного списка на одной строке через 1 пробел
Питон ​

Ответы на вопрос

Ответил Аноним
1

Ответ:

L = [s for s in input().split(',')] #ввод через запятую

M = [s for s in input().split(',')] #ввод через запятую

C = []

if len(L) > len(M):

   N = len(M)

else:

   N = len(L)

for i in range(N):

   C.append(int(L[i]) + int(M[i]))

   print(C[i], end=' ')

Объяснение:

Ответил Fedy16
0

Ответ:

for L, M in zip(input().split(), input().split()):

   print(int(L) + int(M), end=' ')

Новые вопросы