Информатика, вопрос задал nastya230803 , 2 года назад

Сумма цифр.
Напишите программу, которая вычисляет сумму
цифр трехзначного числа.
Пример 1
Ввод:
175
Вывод:
13
(в Python 3)​

Ответы на вопрос

Ответил merkkaa
3

a = 175

a = list(str(a))

summa = 0

for i in a:

   summa += int(i)

print(summa)

------ Либо если явно 3 цифры

a = 175

a = list(str(a))

print(int(a[0]) + int(a[1]) + int(a[2]))

Новые вопросы