Информатика, вопрос задал Tortik20 , 8 лет назад

Срооооочно пожалуйста
Напишите программу на с++, которая вводит натуральное число N и выводит на экран все натуральные числы, не превосходящие N и делящуеся на каждую из своих цифр

Ответы на вопрос

Ответил danulpopov
0
#include <bits/stdc++.h>

using namespace std;

int main()
{
   int n; cin >> n;
   for (int i = 1; i <= n; ++i)
   {
       int tmp = i;
       bool fl = true;
       while (tmp) {
            int x = tmp % 10;
             if (x != 0)
                if (i % x != 0)
                  fl = false;
              if (!x) fl = false;
            tmp /= 10;
       }
       if (fl) cout << i << ' ';
   }
}


Новые вопросы