СРОООЧНО!!!
Нужно написать программу на языке Паскаль
Условие:
Напишите программу,которая вводит с клавиатуры 3 целых числа и записывает в логическую переменную True,если среди введенных чисел есть хотя бы одно трехзначное
stesis:
можно поконкретней
Ответы на вопрос
Ответил stesis
1
Ответ:
var a,b,c,x:integer;
var true : array [1..3] Of integer ;
begin
readln(a,b,c);
if (a div 100 < 10 )and (a div 100 > 1) then
begin
True[1]:=a;
True[2]:=b;
True[3]:=c;
end;
if (b div 100 < 10 )and (b div 100 > 1) then
begin
True[1]:=a;
True[2]:=b;
True[3]:=c;
end;
if (c div 100 < 10 )and (c div 100 > 1) then
begin
True[1]:=a;
True[2]:=b;
True[3]:=c;
end;
write(true);
end.
Объяснение:
если не надо в конце выводить true то можешь просто удалить эту строку
Новые вопросы