Другие предметы, вопрос задал salamatkyzym11 , 2 года назад

сроочнооо
Напишите программу, которая просит пользователя ввести целое число N. Программа должна предлагать пользователю ввести целые числа NxN и сохранить их в двумерном массиве. Затем программа должна определить и вывести «Да», если массив симметричен по диагонали, в противном случае вывести «Нет».

Приложения:

Ответы на вопрос

Ответил Asexo69
1

Ответ:

#include <iostream>

using namespace std;

int main(int argc, char *argv[])

{

int N,i,j,L;

cout << "Vvedi kol-vo elementov: ";

cin >> N;

int a[N];

for(i=0;i<N;i++)

{

cout << "Vvod a[" << i << "] elementa: ";

cin >> a[i];

}

cout << "Vvedi L: ";

cin >> L;

for(i=0;i<N;i++)

{

cout << "a[" << i << "]=" << a[i] << endl;

}

cout << endl;

for(i=0;i<N;i++)

{

if(a[i] > L) a[i] = 5;

}

for(i=0;i<N;i++)

{

cout << "a[" << i << "]=" << a[i] << endl;

}

}

Вот сам код. Надеюсь, что правильно)

Новые вопросы