Информатика, вопрос задал uffuftjnf , 6 лет назад

СРОНО ДАЮ 50 БАЛЛОВ!!!!!!!!!
Напишите программу которая в последовательно натуральных чисел определяет количество честных трёх значных чисел программа получает на ввод натуральные числа количество введённых чисел не известно последовательность чисел заканчивается числом 0.

Ответы на вопрос

Ответил Zergloing
1

Ответ:

s = int(input())

k = 0

while s != 0:

   if len(str(s)) == 3 and s % 2 == 0:

       k += 1

   s = int(input())

print(k)

Объяснение:

В условии написано "честных", но я так понял имеется в виду "чётных". Если верно, то отметь, пожалуйста, как лучший ответ.

Новые вопросы